Patapsco Simulator Quickstart Guide V3.0

Part | Introduction

1
2

Patapsco

Safety warnings

Part Il Getting Started

A Hh ON =

Rack Mounting Instructions
Accessories

Optional Accessories
Making Connections

Installing DbManager

Part lll Configuring Simulator

© 00 N OO 0 A~ ON -

-
o

PATAPSCO

Connecting to Simulator

Notes on configuring Simulator
Device Settings

Clock Sources

PRI Ports

BRI Ports

Configuring Routing Profiles
Using Groups

Finishing Configuration

More Resources

Patapsco Communications,

Passfield Oak, Passfield, Near Liphook, Hampshire, GU30 7RL England
Tel: +44 (0) 1 428 752900 Fax: +44 (0) 1 428 752901

info@patapsco.co.uk www.palapsco.co.uk



2 Patapsco Simulator Quickstart Guide

1 Introduction

This document is a basic guide for configuring a new Patapsco Simulator. A full User Manual for configuring all settings on the unit is supplied on
the DbManager Installation Disk. Patapsco offers an optional Pre-Configuration Service and optional Telephone Support Agreements at minimal
cost. Information on these options is in the Support document on the DbManager installation disk.

1.1 Patapsco

Patapsco Liberator and Simulator products offer a wide range of functions for switching, cross connecting and converting ISDN calls and
elements. More than just a PR/BRI converter; Liberator allow s services using different protocols, such as E1 and T1 to be interfaced together and
managed using a large suite of call routing and manipulation options. Simulator offers much the same functionality as the Liberator products, but all
of its ports are configured as NT (netw ork Termination) for use with end user equipment, offering a completely configurable netw ork simulation
environment.

Please contact Patapsco for any additional information on the product range, or for any other queries regarding communications solutions:

Patapsco Communications -

The Passfield Oak Telephone: +44 (0)1428 752900
Passfield Fax: +44 (0)1428 752901
Liphook

Hampshire email: info@patapsco.co.uk
GU30 7RL

UK Web Site: www.patapsco.co.uk

1.2 Safety warnings

&5 A Caution: Danger of electric shock. The device may be connected to mains wltages. Switch to power-off state
before working on the device.

-

: A caution: Danger of electrostatic discharge. Electronic components are sensitive to electrostatic discharges that
might damage the device. Protect the device from electrostatic discharges by wearing an electrostatic
wristband.

-

_:) Ad caution: Interruption of data transmission. Data transmission will be interrupted during any work on the
transmission line and/or deactivation of the power supply. Make sure that that any work will only be carried out
on inactive lines (without data transmission) or during quiet times to reduce interference to live systems.

— Caution: Danger of damage to devices or senice interruption. Access by unauthorized third persons may cause
damage to devices and/or interrupt senices. Make sure that subracks are only installed in lockable locations.

) A caution: Danger of overwltage. During faults, dangerous unprotected wltages may be present. Ensure
sufficient grounding of the housings, i.e. by connecting the grounding contact.

e  Safety requirements are not fulfilled unless this equipment is connected to a wall socket outlet with a protective earth
(PE) contact.

e  The power cord used to connect this equipment must be HAR marked and fitted with an IEC320 connector and an
ASTA approved moulded plug.

e  There are no user seniceable parts in this equipment. All senicing and repair tasks must be undertaken by qualified
service personnel.

. Isolation from mains power is achieved by the removal of the main power cord.
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Getting Started

This section w ill describe how to make the physical connections betw een Simulator and the other system devices, and install the Patapsco
management application, DbManager.

Rack Mounting Instructions

The Rack Mounting Kit is comprised of the follow ing:

Description Quantity
L-Bracket 2

Long Patapsco case screw 4

Fr‘hoto

-

=
b Cage Nut 4
o

—

washer 4

Rack Mount Screw 4

All Patapsco units can be mounted in a standard 19" rack housing. To allow units to fit into a 19" rack, a Rack Mounting Kit must be purchased for
the unit(s). There are various rack mounting options depending on the size of the unit ordered. The follow ing guide w ill explain how to use the
Rack Mounting Kit w ith Patapsco units.

1. Remove the four short screw s near the front or rear panel on the left and right hand sides of the Patapsco unit. The unit can be mounted w ith
the front panel facing forw ard or w ith the ports facing forw ard as required.

2. Fit one of the L-Brackets to the side of the unit. The four small fixing holes allow the unit to protrude forw ard or sit further back depending on
the desired position of the unit. The bracket may also face forw ards or backw ards depending on the desired position of the unit.

3. Fix the L-Bracket in place using the Long Patapsco case screws.
4. Fix the second L-Bracket to the other side of the case in the same w ay.
5. Put the Rack Mount screws through the Rack Mount washers.

6. Offer the unit up to the rack and fix it in place using the Rack Mount Screws and Rack Mount cage nuts.

Accessories

The follow ing accessories are supplied w ith all Patapsco units:

fitem Description
DbManager CD Installable DbManager application, technical documents and manuals
Cable Spec
Controller Cable Management cable. Connects to RJ12 DB9S
Simulator's Terminal port Pin Function Pin
1 Rx 3
2 Tx 2
3 Gnd 5
IEC Mains Cable Connects Simulator to the mains supply

Optional Accessories

The follow ing items can be ordered from Patapsco, or will be supplied w ith some units depending on the nature of the device.

ISDN Cables - Cables to connect the Patapsco device to a CPE or netw ork. Please see the full manual for cable specs on
all Patapsco cables

Patapsco Communications Passfield Oak, Passfield, Liphook, Hampshire GU30 7RL England
Tel: +44 (0) 1428 752900
Fax: +44 (0) 1428 752901
www.patapsco.co.uk



24

2.5

4 Patapsco Simulator Quickstart Guide

Rack Mounting Kit - All Patapsco units can be monuted in a 19" rack using this kit

Making Connections

First, connect the ISDN cables to Simulator follow ed by the Terminal Port management cable (if required), LAN Port cable and lastly the Mains
cable. If the unit has a DC pow er supply connection, use the screw terminals to connect the DC pow er source.

&5 Warning: The -48VDC power terminals are marked 0V, -48V, and GND. Patapsco -48VDC products are designed for
use with negative wltage DC supplies, and therefore expect the positive wltage to be connected to the 0V terminal,
and the negative connected to -48V. Please be sure about the polarity of this connection before connecting power to
the terminals. Units which have a positive +24VDC power source will be marked +24VDC, 0V and GND respectively.
Please ensure that the positive connection is made on the +24VDC terminal.

Installing DbManager

DbManager is required in order to monitor and manage Patapsco devices. Management can be made using the Terminal (serial) port, or using TCP/
IPover a LAN or WAN. DbManager is installed using the CD provided w ith Patapsco equipment.

1. Insert the DoManager Installation Disk into the drive of the PC w hich w ill be used for management of Simulator.
2. InstallShield Wizard will start up. Follow the steps to install DbManager.
3. Serial Number — Enter the Serial Number on the case of the DbMgr Disk.

Y Info: DbManager is supplied as a 'Lite' version by default. This allows configuration and monitoring of devices, but
only allows configuration of a single device node and a single user account. To use DbManager in 'Lite' mode, do not
enter a serial number during installation. Please see the full DbManager User Manual for more information on
configuring and using DbManager.

&5 Warning: If an older version of DbManager is already installed on the management PC, it is necessary to update to
the version supplied on the new DbManager CD. This can be done by consulting the ‘Upgrade’ folder on the
DbManager CD. The ‘readme.txt’ file explains how to upgrade to the new DbManager without reinstalling the program.

Configuring Simulator

Follow these steps to connect to Simulator w ith DbManager and configure the unit for use.

Configuration of Simulator is carried out by setting up DbManager to make a management connection, and then setting up the elements of Simulator
in this order:

Device Settings - The unit-specific settings of the Simulator such as the IP Address and Identifier
Clock Sources - configure w hich interface Simulator is to take synchronisation clock from, typically a connected device
ISDN Ports - Each ISDN port can be individually configured w ith the correct settings to interface with another device

Link Configuration - Configure settings to carry ISDN channels across a PSN betw een Simulator units

Call Routing - Configure routes for the traffic Simulator will pass betw een connected devices




3.1

Configuring Simulator 5

Connecting to Simulator

1. Start up the DoManager Application
2. Login as Super User (no passw ord required)
3. Four window s will be displayed:

Map A network map showing Nodes and Links between Patapsco devices
L s
EETTETET .o
Terminal A view of the communications between DbMgr and Simulator
Event History All events which occur while connected to Simulator
Outstanding Events Current events
b |

4. Select View > Properties > Terminal from the DbMgr toolbar.

5. Choose the COM port w hich is in use. Leave the Serial Port Rate at the default setting of 19200bps. Click OK.

6. Select the Devices in World window and double click the Device node

7. The Connected to Device window should appear, show ing the front and rear panels of Simulator. If it does not, check the COM port settings
and re-try

& Warning: If management via the Terminal port is not possible, it could be that the management PC has another
application running which uses the COM ports of the PC. Even when some programs which use the COM ports are
closed down, other programs cannot access the COM ports. Rebooting the PC is required in order to release the
COM ports so that DbManager can use them.

If the PC and Simulator are connected to the same LAN, management is possible using TCP/IP. All Patapsco products use the default IP settings:

IP Address 192.168.0.1
Subnet Mask 255.255.0.0
Gateway 0.0.0.0

To configure DbManager to access Simulator using TCP/IP, please follow these steps:

1. Select View > Properties - Terminal = Device IP Addresses from the DoMgr toolbar
2.192.168.0.1 should already be configured. If using another IP address, add it to the list using the Add button
3. Click OK > OK

4. Select the Devices in World window and double click the Device node

5. The Connected to Device window should appear, show ing the front and rear panels of Simulator

The Device node can be made to connect to other IP addresses configured in the Device IP Addresses list by right-clicking the node, selecting
Properties and choosing an IP address fromthe IP List.

" Info: TCP/IP management requires TCP port 3001 (dec) to be open between the management PC and Simulator. Any
switches, hubs or routers must be configured to allow communication on this port in order to manage Simulator via
TCP/IP.

Patapsco Communications Passfield Oak, Passfield, Liphook, Hampshire GU30 7RL England
Tel: +44 (0) 1428 752900
Fax: +44 (0) 1428 752901
www.patapsco.co.uk
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A successful management connection w ill open up the Connected to Device window :

= Connected to Device =101 x|

(NTIPri22 Pri2t(NT)
hains

oC
L]
a0y

(NT)Priz3__Lan

Notes on configuring Simulator

1 Uploading

Changes to config can be made on each window and saved using the OK key when exiting each window. When happy
with the configuration, it must be uploaded to Simulator for the new settings to come into effect.

To upload, go to File > Upload and wait until the progress bar completes.

1 Saving Files

Configuration files can be saved in order to backup settings or copy settings across to another unit. Once configuration
has been uploaded, go to File > Save File and choose a location to sawe the file to.

1 Loading Files

Once connected to a unit, an existing configuration file can be loaded to the device. Go to File > Open File and navigate
to the saved file. Click Open. Now the file must be uploaded to Simulator. Go to File > Upload and wait until the
progress bar completes.

—* Warning: When loading existing configuration files to a unit, please ensure that the correct configuration files are
used for the unit type in use. Simulator configuration files are not compatible with other Patapsco platforms.

Device Settings

This menu controls unit-specific features of the Simulator such as the IP Address, Identifier, Serial Number, Configuration Number, Time & Date and
Event Reporting. These features are all fully explained in the Simulator User Manual on the DbManager Installation Disk.

Clock Sources

Simulator must be configured to either receive clock from an ISDN interface or generate clock internally. Different priorities can be set for each
port, so if one port is unavailable, Simulator w ill clock from the next available port in the Clock Source hierarchy.

1. Select Clock Sources fromthe Terminal port menu.

2. Enter a digit to mark the priority of each ISDN port and the internal clock. 0 w ill denote the highest priority Clock Source and 19 w ill denote the
low est. Ports w hich are not to be used for clocking can have their values left at 19.

3. Click OK to save the setting.

T . . .
—= 2 Warning: Clock Sources must be configured correctly to ensure error-free operation when Simulator is connected to
any other clock-locked system or network. Please consult the full Simulator manual if unsure how to configure Clock
Sources.
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PRI Ports

There are tw o LEDs for each PRI port, and the LED states are as follow s:

Top LED on - Layer 1 and 2 established
Top LED flashing - Layer 1 established, trying to synchronize with Layer 2
Bottom LED on - Calls active on interface

1. Click on an enabled PRI port.

2. The configuration settings for the port are displayed.
3. Configure the settings as required for the port.

4. Click OK to save the settings.

BRI Ports

There are tw o LEDs for each BRI port, and the LED states are as follow s:

Top LED on - Calls active on B channel number 1
Bottom LED on - Calls active on B channel number 2
LEDs off - No calls active on interface

1. Click on an enabled BRI port.

2. The configuration settings for the port are displayed.
3. Configure the settings as required for the port

4. Click OK to save the settings.

Configuring Routing Profiles

It is strongly recommended that you draw a simple diagram show ing the Simulator, its ISDN ports in use, the DDl numbers, and any local devices
and the number ranges used to access them. An example is show n below .

Video Conferencing PRI 22

PABX

This example requires that Simulator routes calls as follow s:

1. Route calls from PABX to the VC
2. Route calls fromthe VC to the PABX

These actions can be catered for using tw o Call Routing Profiles. A Call Routing Profile is used to direct traffic from one port or group of ports to
another. A Routing Profile has many options to control how calls are routed, but in this case and in most applications the Routing Profile wiill
consists of the follow ing elements:

Name, Source, Destination(s), DDIs
Click on the Terminal port and select Call Routing from the Drop-Dow n menu to configure routing profiles for Simulator.

1. The Call Routing Profiles List is displayed. This will show all Routing Profile details w hen they are configured.

2. Select Add Profile and choose Add Routing Profile.

3. Name the profile and tick the Enable check-box.

4. Move the SOURCE PORTS radio button to Select and enter a source for incoming calls. A source can be designated by entering a port number,
port and channel number or by using a Group of ports and/or channels:

Patapsco Communications Passfield Oak, Passfield, Liphook, Hampshire GU30 7RL England
Tel: +44 (0) 1428 752900
Fax: +44 (0) 1428 752901
www.patapsco.co.uk
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To use a port: Enter the port number (e.g. 21 for PRI21, 1 for BRI 1)

To use a port and Enter the port number follow ed by a full stop and then the channel number (e.g. 21.1 for PRI 21 channel 1, 1.1 for BRI
channel: 1 channel 1)

To use a Group: Configure a group and select it from the Drop-Dow n menu (see 5.2 for instructions on configuring a group)

5. Move the DESTINATION PORTS radio button to Select, and enter a destination for calls in the same w ay as the SOURCE PORTS
6. Select the Incoming Numbers tab to choose numbers w hich Simulator wiill use to route the calls.

1 Note: If no Incoming Numbers are configured (*/*), Simulator will route all calls received on the Source ports to the
Destination ports, regardless of the DDI, CLI or SubAddress numbers of the call.

7. The DDI Listing defaults to */* w hich represents any number and any SubAddress (Number/SubAddress).

8. Double click the */* to edit the number values. An entry of *1234/* w ould route any call w ith a DDI ending in 1234 w ith any SubAddress. Right-
clicking an existing entry w ill present more options.

9. Enter a CLI value if required. This is entered in the same w ay as the DDI. The default value; * will route calls with any CLI.

" Note: More routing options may be used to configure complex routing profiles. These are all explained in the
Simulator manual on the DbManager installation disk.

10. Click OK on the tw o active window s and the new routing profile will appear in the Call Routing Profiles List.
11. Click Exit to return to the Connected to Device window .

Prioritizing Routing Profiles

The Call Routing Profiles List show s all configured Call Routing Profiles in order of priority. These priorities can be rearranged to allow diverse
routing possibilities. When Simulator receives a call, it will check each profile in order from the top of the list for any routing parameters matching
those of the call. It will route the call based on the first matching profile.

1. Select Call Routing from the Terminal port Drop-Dow n menu.

2. All configured routing profiles are displayed.

3. Right click on a profile in the Type column to display options. The profile can be promoted or demoted in the priority list. There are also options to
edit and delete the profile.

This table show s the profiles w hich w ould be required to carry out the call routing show n in the diagram above:

Profile Number Profile Name Source Primary Destination Secondary Destination | DDIs

0 ISDNto VC 21 1 Group: BRI 1-4 *981/* - *088/*
1 ISDN to PABX 21 22 I

2 Outgoing All Ports 21 *I*

Provided profile 0 is at the top of the priority list (see Prioritizing Routing Profiles, above), Simulator w ill route calls w ith DDI ending in 981-999
to the VC and all other calls to the PABX. The first profile uses both a Primary and Secondary destination because VC equipment requires the first
call from the ISDN to arrive on BRI 1. This VC feature (Channel Bonding) is explained further in the Simulator manual. Note that in this case, all the
DDI numbers from *980/* to *999/* are configured in the DDl list of profile 0. All calls going out to the PSTN from both the VC and PABX w ill be
routed out using profile 2.

With all of these profiles configured, the Call Routing Profile List screen should look like this:

Type | |ndex | |dentifier | Enabled | Source | 1zt Destination | 2nd Destination | DD Mumber |
ROUTING 1] IS0 ta W YES 21 1 BRI 1-4 e
ﬁHDUTING 1 ISDH to PABX  YES 21 22 Ay

ﬁ ROUTIMG 2 Outgoing YES All Ports 21 Ary
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Clicking on Sort on DDIs show s all of the DDI numbers configured in the Incoming Numbers listing:

DO Murnber | |ndex | | dentifier | Type | E nabled | Source | 1zt D estination | Znd Deztination |
0: =881~ 1] ISOM ta T ROUTIMG  YES 21 1 BRI 1-4
1. #8982~ 1] ISOM b T ROUTING  YES 21 1 BRI 1-4
s o T 1] ISOM ta T ROUTIMG  YES 21 1 BRI 1-4
s o M 1] ISOM b T ROUTING  YES 21 1 BRI 1-4
4 #9ERM~ 1] ISOM ta T ROUTIMG  YES 21 1 BRI 1-4
B *9B6/~ 1] ISOM b T ROUTING  YES 21 1 BRI 1-4
B *987. 1] ISOM ta T ROUTIMNG  YES 21 1 BRI 1-4
Fs =i T 1] ISOM b T ROUTIMG  YES 21 1 BRI 1-4
0 = 1 ISOM ta PABX  ROUTING  YES 21 22

0 == 2 Cutgaoing ROUTIMG  YES All Portz il

Using Groups

When more than one port needs to be configured as a source or destination for calls, a Group of ports can be set.

1. Select Add Group fromthe Add Routing Profile screen.

2. The Group Configuration screen is displayed.

3. Name the Group you wish to configure.

i .'\I . . . .

“= Note: The names of any Routing Profiles, Groups and Identifiers must not contain the following characters: <> ~

4. Use the All and None buttons to add blocks of PRI and BRI ports to the Group, or select individual channels from each port by using the tick-
boxes.

5. Click OK to save the group.

6. The new Group will now appear in the SOURCE and DESTINATION drop-dow n menus. Select this Group from the drop-dow n to use it in a Call
Routing Profile.

Finishing Configuration

"’ Note: Please remember to Upload when configuration of Simulator is complete. To upload, go to File > Upload
and wait until the progress bar completes.

More Resources

All Patapsco products and the DbManager application have their ow n User Manuals w hich can be found in the 'Documents & Manuals' folder on
the DbManager installation disk. Please consult these manuals for more detailed information on any aspect of using Patapsco products. All
documentation can also be obtained by registering at the Patapsco w ebsite:

http://w w w .patapsco.co.uk/Top_Level/Login_Register.asp

For help with a specific problem, please click on the On-Line Help icon on the w ebsite, or email a request to support@patapsco.co.uk

Patapsco Communications Passfield Oak, Passfield, Liphook, Hampshire GU30 7RL England
Tel: +44 (0) 1428 752900
Fax: +44 (0) 1428 752901
www.patapsco.co.uk
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